> a) Rename winsock.c to w32sock.h. > Create a file connect.c containing > > #define GNULIB_CONNECT 1 > #include "w32sock.h" > > and similarly for the other modules that make up winsock.c. > > Remove the gl_MODULE_INDICATOR([$1]) line from the definition of > gl_SYS_SOCKET_MODULE_INDICATOR. > > b) Split winsock.c into accept.c, connect.c, etc. - like we are doing > in gnulib for most other functionalities. The inline functions > (FD_TO_SOCKET, SOCKET_TO_FD, set_winsock_errno) can go to a private > header file, let's say, w32sock.h or socket-internal.h. > > I would prefer b), because it's leads to a more understandable code structure.
I have no particular preference. Paolo