vasnprintf.c uses variables named exp and remainder, and they shadow math functions. This poses a problem for me, since coreutils' "make distcheck" requires a clean build with -Werror -Wshadow.
Bruno, any objection to this change? >From a492d243a5d6359642e94abea4b292f86a07caa5 Mon Sep 17 00:00:00 2001 From: Jim Meyering <[EMAIL PROTECTED]> Date: Fri, 16 May 2008 23:40:04 +0200 Subject: [PATCH] Rename locals to avoid shadowing warnings. * lib/vasnprintf.c (exp): #define to vasnprintf_exp. (remainder): #define to vasnprintf_remainder. --- lib/vasnprintf.c | 3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/lib/vasnprintf.c b/lib/vasnprintf.c index 517888c..79c20af 100644 --- a/lib/vasnprintf.c +++ b/lib/vasnprintf.c @@ -85,6 +85,9 @@ # endif #endif +#define exp vasnprintf_exp +#define remainder vasnprintf_remainder + /* Checked size_t computations. */ #include "xsize.h" -- 1.5.5.1.249.g68ef3