Jim Meyering wrote:
> I know you didn't change the single quotes (maybe it's Bruno's
> stylistic preference to use them?)

Yes, it's my stylistic preference.

> but they are superfluous. There's less syntax this way:
> 
>     libname_upper=`echo "$libname" | LC_ALL=C tr a-z- A-Z_`

But it's not more readable this way.

One can remove the surrounding quotes of sed arguments:
  sed -e s/\\/[^/]\*\$//
but it doesn't become more readable this way.

One can remove the surrounding quotes in variable assignments:

  backup_file=$dir/$file~

but it's more maintainable this way:

  backup_file="$dir/$file"'~'

Bruno



Reply via email to