Bruno Haible <[EMAIL PROTECTED]> writes: > Additionally, can we please add a comment here?
Sure. For consistency there should be a comment for canonicalize_filename_mode so I installed the following patch for canonicalize.h along with the other patches already mentioned. Another consistency change: canonicalize_filename_mode should be renamed to canonicalize_file_name_mode as per the GNU coding standards. Any objections? (Jim? :-) --- lib/canonicalize.h 3 Nov 2006 23:17:27 -0000 1.4 +++ lib/canonicalize.h 6 Nov 2006 18:20:30 -0000 @@ -33,12 +33,21 @@ enum canonicalize_mode_t }; typedef enum canonicalize_mode_t canonicalize_mode_t; +/* Return a malloc'd string containing the canonical absolute name of + the named file. This acts like canonicalize_file_name, except that + whether components must exist depends on the canonicalize_mode_t + argument. */ char *canonicalize_filename_mode (const char *, canonicalize_mode_t); # endif # if HAVE_DECL_CANONICALIZE_FILE_NAME # include <stdlib.h> # else +/* Return a malloc'd string containing the canonical absolute name of + the named file. If any file name component does not exist or is a + symlink to a nonexistent file, return NULL. A canonical name does + not contain any `.', `..' components nor any repeated file name + separators ('/') or symlinks. */ char *canonicalize_file_name (const char *); # endif