Bruno Haible <bruno <at> clisp.org> writes:

> Yes; it does not make sense for a library to call a function that may call
> xalloc_die(). Using xvasprintf results in small and maintainable code.
> You could also do it without xvasprintf: perform similar code as in
> error.c, really calling vfprintf.

But that is exactly what I am hoping the glibc maintainers will do - add verror 
to their interface, then our verror module can probably be obsoleted in favor 
of our error module matching their interface.  But getting glibc to change is a 
slow process, so I settled for verror in the meantime, which can call 
xalloc_die, rather than duplicating and having to maintain a lot of code.

> To avoid the code duplication, you
> could move the bulk of code from error.c to verror.c and then have the
> 'error' module rely on 'verror'.

Indeed.  But that sentiment of code sharing is exactly opposite your original 
rejection of my proposed changes of adding verror in the error module.  I don't 
want error to depend on verror, because then it makes our separation from glibc 
that much harder to overcome.  I had to settle for the reverse; verror 
depending on error.

-- 
Eric Blake




Reply via email to