http://sourceware.org/bugzilla/show_bug.cgi?id=15662
--- Comment #1 from Cary Coutant <ccoutant at google dot com> --- > Index: powerpc.cc > =================================================================== > RCS file: /cvs/src/src/gold/powerpc.cc,v > retrieving revision 1.91 > diff -r1.91 powerpc.cc > 2631a2632 >> this->brlt_section_->reset_rel_data_size(); > 2638a2640 >> this->brlt_section_->finalize_rel_data_size(); This looks right to me, but Alan should confirm. I'd suggest, instead of adding a second call at each point, replacing the call to reset_data_size and finalize_data_size with calls to reset_brlt_sizes and finalize_brlt_sizes, and have those functions make both calls that are needed. > 3015a3018,3029 >> void >> reset_rel_data_size() >> { >> this->rel_->reset_data_size(); >> } >> >> void >> finalize_rel_data_size() >> { >> this->rel_->finalize_data_size(); >> } These member functions would then become: void reset_brlt_sizes() { this->reset_data_size(); this->rel_->reset_data_size(); } void finalize_brlt_sizes() { this->finalize_data_size(); this->rel_->finalize_data_size(); } (By the way, in the future, please use 'diff -up' to generate your patches -- it makes them much easier to read.) -cary -- You are receiving this mail because: You are on the CC list for the bug. _______________________________________________ bug-binutils mailing list bug-binutils@gnu.org https://lists.gnu.org/mailman/listinfo/bug-binutils