Alexandre Duret-Lutz <[EMAIL PROTECTED]> writes: > SJ> How about simply: > > SJ> tests_PROGRAMS += test-gc > [...] > SJ> Or something, I'm not really sure. I have always found this > SJ> redundancy a bit disturbing though. > > I don't think a new syntax is necessary since you can do > > TESTS = $(testprograms) other scripts > check_PROGRAMS = $(testprograms) other programs > > and then > > testprograms += test-gc$(EXEEXT) > testprograms += test-whatever$(EXEEXT) > ... > > (And with the patch below you won't need $(EXEEXT).)
Right, that is sufficiently simple for me. I wonder what the best idiom for gnulib should be. We probably do not want to require automake CVS just yet. Should it be the one I'm using: TESTS += test-gc$(EXEEXT) check_PROGRAMS += test-gc or should we do selftests = test-gc$(EXEEXT) TESTS += $(selftests) check_PROGRAMS += $(selftests) Opinions? I haven't tested that the latter works, but based on what you write, I assume it does. Once we require the next automake release, the $(EXEEXT) could be removed. > Append $(EXEEXT) to programs that may be listed in TESTS. > Report from Simon Josefsson. Is this on the CVS trunk? Is there any other automake branch one should pay attention to, in general? Thanks!